Not Connecting In 4G

SOLVED
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Talker

Not Connecting In 4G

My mobile (Lenovo P70) isn't connecting to ooredoo 4G network. Last Friday, I went to Doha Corniche. Then I tried to connect to data. It connected on 3G network not on 4G even though my phone has 4G.

I'm sure that my settings are correct. In addition, it connects to Vodafone's 4G.

Please reply ASAP. 

 

P.S. I know that I have to insert the sim in slot 1 to work. I've changed. didn't work.

3 REPLIES
Champion

Re: Not Connecting In 4G

It seams like your phone doesn't support the frequencies used by ooredoo for the 4G network.

Ooredoo uses 800 MHZ and 2600 MHZ for their 4G coverage, and rarely 1800 MHZ. Your device seams to be only supporting 1800 MHZ out of the 3 ooredoo uses.

Please ask your device manufacturer if they support the 3 I mentioned for the model you have. If they don't you might need to get another phone, or just give up 4G on ooredoo.
Not an Ooredoo employee. Please mention me (@MRizkBV) when you need help so that I get an instant email notification!
Don't forget to follow me on: Twitter (@MRizkBV) - PSN: MRizkBV - Xbox Live: MRizkBV
Talker

Re: Not Connecting In 4G

[ Edited ]

@MRizkBV Sorry for my late reply -too late Smiley Tongue-, it's solved. I just had to change my SIM card. It was too old (bought that SIM in 2003). And BTW, the phone supports the 3 frequencies that you've mentioned.
Thank you.

Re: Not Connecting In 4G

Tro to do these settings again in your phone:

  • Tap Settings on Home screen.
  • Tap SIM management.
  • Turn on the switch on its right, choose your carrier's mobile network in Data connection to connect (eg. 3G, 4G).

for more details refer to Lenovo P70 Manual.